Degraded performance: Analytics, notifications, mobile apps

Incident Report for Circle

Resolved

AWS has resolved the incident. All systems are operating normally. We’ll continue to monitor for stability.
Posted Oct 20, 2025 - 22:02 UTC

Monitoring

In-app notifications and analytics features are now fully operational. We will continue to monitor closely to ensure stability.
Posted Oct 20, 2025 - 19:55 UTC

Identified

We’re investigating performance issues caused by the global AWS outage also impacting Amazon, Snap, Venmo, and others. See status tracker from AWS and news coverage below. Our team is standing by for resolution and will keep you informed of any changes.
-AWS Status tracker: https://health.aws.amazon.com/health/status
-News coverage: https://www.cnn.com/business/live-news/amazon-tech-outage-10-20-25-intl
Posted Oct 20, 2025 - 16:29 UTC
This incident affected: Apps (Circle Android App, Branded Apps) and Communities (Notifications, Analytics).