Elasticsearch Degradation

Incident Report for Circle

Postmortem

Search functionality was degraded starting at approximately 6:52 PM EDT on April 14. The issue was caused by Elasticsearch cluster degradation. An incident report was filed internally. This issue should have had a status page entry since customers reported broken search.

Customers checking status.circle.so saw 'All Systems Operational' during this period.

Posted Apr 15, 2026 - 20:04 UTC

Resolved

Search functionality was degraded starting at approximately 6:52 PM EDT on April 14. The issue was caused by Elasticsearch cluster degradation. An incident report was filed internally. This issue should have had a status page entry since customers reported broken search.

Customers checking [status.circle.so](http://status.circle.so) saw 'All Systems Operational' during this period.
Posted Apr 14, 2026 - 11:50 UTC