app.circle.so is down

Incident Report for Circle

Postmortem

Brief disruption (~2 min) at 6:40 AM EDT caused by a memory leak in web application pods. Pods exceeded their memory limits and were automatically restarted by the infrastructure. Our team increased the minimum pod count and enabled memory-based autoscaling at 70% threshold to prevent recurrence. Investigation into the root cause of the memory leak is ongoing.

Posted Apr 15, 2026 - 20:11 UTC

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 10:42 UTC

Investigating

We are currently investigating this issue.
Posted Apr 10, 2026 - 10:40 UTC