app.circle.so is down

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 13:52 UTC

Investigating

We are currently investigating this issue.
Posted Feb 26, 2025 - 13:07 UTC