app.circle.so is down

Incident Report for Circle

Postmortem

Communities experienced approximately 3 minutes of degraded availability at 4:21 PM EDT. The issue was caused by an unoptimized database query in the live streams feature making 71 calls per second to the primary database. Our team identified the specific query and deployed a fix the same day to reduce query frequency.

Posted Apr 15, 2026 - 20:09 UTC

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 20:24 UTC

Investigating

We are currently investigating this issue.
Posted Apr 13, 2026 - 20:21 UTC
This incident affected: Communities (Sign-up & Login, Posts & Comments, Notifications, Direct Messaging & Chat, Paywalls & Member Billing, Live Streams & Rooms, Courses, Events, Marketing Hub, Workflows, Analytics), Developer API (REST API), Apps (Circle iOS App, Circle Android App, Branded Apps), and Circle Discover, Circle Help Center.