Mobile API endpoint errors

Incident Report for Circle

Postmortem

Mobile API endpoints experienced intermittent 500 errors starting at 6:57 AM EDT on April 9. This was caused by a Rails 8.1 regression where a change in how ActiveSupport::CurrentAttributes managed state between requests caused crashes in OpenTelemetry instrumentation. Affected workers returned errors on every request, including health checks, causing pods to restart repeatedly. The root cause was identified at 7:45 AM EDT, and a fix was deployed. This issue should have had a status page entry since it impacted customers using the mobile app.

Posted Apr 15, 2026 - 20:17 UTC

Resolved

Mobile API endpoints experienced intermittent 500 errors starting at 6:57 AM EDT on April 9. This was caused by a Rails 8.1 regression where a change in how ActiveSupport::CurrentAttributes managed state between requests caused crashes in OpenTelemetry instrumentation. Affected workers returned errors on every request, including health checks, causing pods to restart repeatedly.

The root cause was identified at 7:45 AM EDT, and a fix was deployed. This issue should have had a status page entry since it impacted customers using the mobile app.
Posted Apr 09, 2026 - 15:57 UTC