app.circle.so is down

Incident Report for Circle

Postmortem

Communities experienced approximately 2 minutes of degraded availability starting at 10:26 AM EDT. The issue was caused by application servers returning 500 errors due to a combination of unoptimized database queries and a framework regression that affected health checks, causing pods to cycle. Multiple engineering teams responded and deployed a fix.

Root cause: A Rails 8.1 upgrade changed how internal state was managed between requests, causing intermittent crashes. This was compounded by high-frequency queries that increased database load. Both issues have been patched.

Posted Apr 15, 2026 - 20:20 UTC

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 14:28 UTC

Investigating

We are currently investigating this issue.
Posted Apr 07, 2026 - 14:26 UTC