app.circle.so is down

Incident Report for Circle

Postmortem

Degraded Performance on March 17th, 2026.

Incident Summary

Between 17:00 UTC and 18:20 UTC, we experienced a partial outage and degraded performance across the platform. During this time, some actions may have been slow to load or temporarily unresponsive.

Root Cause

The issue was caused by a disruption in one of our supporting database services. This led to some requests taking longer than expected, which impacted overall application performance.

Resolution

We restored the affected service, and performance returned to normal shortly after.

Prevention & Next Steps

We’re taking the following steps to reduce the likelihood of this happening again:

  • Improving the reliability and monitoring of the affected service
  • Adding safeguards so the platform continues to operate smoothly even if a supporting service becomes unavailable

We appreciate your patience while we worked to resolve this and apologize for the disruption.

Posted Mar 17, 2026 - 20:46 UTC

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 18:21 UTC

Investigating

We are currently investigating this issue.
Posted Mar 17, 2026 - 17:07 UTC