app.circle.so is down

Incident Report for Circle

Postmortem

Post-Mortem: Service outage on Apr 8, 2025.

Incident Duration:

  • Start: April 8, 2025, at 5:08 PM UTC.
  • End: April 8, 2025, at 5:40 PM UTC.

Impact:
On April 8th, 2025, between 5:08 PM UTC and 5:40 PM UTC, our application experienced an outage, making it temporarily unavailable.

Root Cause:
The incident was caused by performance issues in one of our databases, which could not handle the incoming load during peak usage, leading the application to become unresponsive and, ultimately, causing the downtime.

Resolution:
Our team quickly identified the issue and implemented changes to reduce the strain on the database, particularly on high-traffic pathways. These adjustments helped restore service within 32 minutes.

Next Steps:
To minimize the risk of this happening again, we are:

  1. Working closely with our database vendor’s support team to address the root cause.
  2. Making further optimizations to reduce database load and improve stability.

We sincerely apologize for the disruption and thank you for your patience and cooperation while we worked diligently to resolve the issue. If you have further questions or concerns, please contact our support team at support@circle.so.

Posted Apr 08, 2025 - 22:43 UTC

Resolved

This incident has been resolved. More information will soon be shared in a postmortem article.
Posted Apr 08, 2025 - 17:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 08, 2025 - 17:40 UTC

Investigating

We are currently investigating this issue.
Posted Apr 08, 2025 - 17:08 UTC
This incident affected: Communities (Sign-up & Login, Posts & Comments, Notifications, Direct Messaging & Chat, Paywalls & Member Billing, Live Streams & Rooms, Courses, Events, Marketing Hub, Workflows, Analytics).