Degraded performance: Android app

Incident Report for Circle

Postmortem

Some older Android devices couldn’t connect after new SSL certificates were installed. The new Sectigo certificate required a root certificate that older Android versions didn’t have, causing the connection failures. We fixed the issue by adding the missing intermediate certificates, and all affected Android devices are now working properly.

Posted Oct 21, 2025 - 18:59 UTC

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 18:53 UTC

Investigating

We are experiencing instability on a small percentage of Android devices and are currently investigating the issue.
Posted Oct 21, 2025 - 13:55 UTC
This incident affected: Apps (Circle Android App).