app.circle.so is down

Incident Report for Circle

Resolved

The issue has been identified and a fix was implemented.
Posted Sep 18, 2025 - 11:25 UTC

Investigating

We are currently investigating this issue.
Posted Sep 18, 2025 - 10:26 UTC