app.circle.so is down

Incident Report for Circle

Resolved

Earlier today, we experienced a brief service disruption from 9:59–10:50 AM ET during a scheduled security update. Service has been fully restored, and we've put safeguards in place to prevent this from happening again. We apologize for any inconvenience.
Posted Sep 01, 2026 - 14:50 UTC

Investigating

We are currently investigating this issue.
Posted Sep 01, 2026 - 13:59 UTC