app.circle.so is down

Incident Report for Circle

Postmortem

Brief disruption detected at 11:05 PM EDT. Services recovered quickly. The status page remained open longer than the actual impact due to a delay in manual close. Actual customer-facing downtime was likely under 5 minutes.

Posted Apr 15, 2026 - 20:25 UTC

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 05:45 UTC

Investigating

We are currently investigating this issue.
Posted Apr 04, 2026 - 05:40 UTC