Degraded performance for user's in West Coast (USA).
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Feb 16, 2022 - 00:24 UTC
Investigating
Cloudflare is Observing Possible Network Performance Issues in West Coast (USA).
https://www.cloudflarestatus.com/
Posted Feb 15, 2022 - 21:22 UTC
This incident affected: Circle Communities (Circle Website, Signup / Login, Posts, Direct Messaging, Analytics).